What's new
Carbonite

Welcome to Carbonite! Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Please help. Work-around for telkom mail on outlook 2019

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
So Telkom decided that they are not supporting Office 2016, 2019 and 365.

Does anyone have an idea how to bypass their stupidity?

I have tried all their different SMTP servers on port 25. Nada.
By the way, the incoming mail works, but outgoing fails every time. I get a message that the mail server does not support the authentication. I have tried none and tls as well as port 587. It just fails.

Any help will be appreciated!
 

PaladinLaw

Member
Rating - 100%
12   0   0
Joined
Mar 4, 2019
Messages
407
Reaction score
223
Points
945
Age
29
Location
Boksburg, Johannesburg
Have you tried this

POP3 Incoming mail server:pop3.telkomsa.net
Outgoing mail server (SMTP):smtp.dsl.telkomsa.net [if you use ADSL], smtp.telkomsa.net if not, or smtp.saix.net or smtp.saix.co.za
Username: full email address [as provided by Telkom Internet]
Password: mail account password [as provided by Telkom Internet]

In Outlook you will need to go to More Settings
On the Outgoing Server tab, leave the checkbox indicating “My outgoing server (SMTP) requires authentication” unchecked
Under the Advanced tab
Incoming server (POP3):
110
Leave unchecked “This server requires an encrypted connection (SSL)”
Outgoing server (SMTP):
25
Set the “Use the following type of encrypted connection:” to None
Other settings are at your discretion
 

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
Have you tried this

POP3 Incoming mail server:pop3.telkomsa.net
Outgoing mail server (SMTP):smtp.dsl.telkomsa.net [if you use ADSL], smtp.telkomsa.net if not, or smtp.saix.net or smtp.saix.co.za
Username: full email address [as provided by Telkom Internet]
Password: mail account password [as provided by Telkom Internet]

In Outlook you will need to go to More Settings
On the Outgoing Server tab, leave the checkbox indicating “My outgoing server (SMTP) requires authentication” unchecked
Under the Advanced tab
Incoming server (POP3):
110
Leave unchecked “This server requires an encrypted connection (SSL)”
Outgoing server (SMTP):
25
Set the “Use the following type of encrypted connection:” to None
Other settings are at your discretion
Hey thanks man, but yes...did all of that. Unbelievable that they can't update their mail server and also not make it more secure. But it definitely seems that they are focusing on Mobile so letting all the "old" stuff go!
 

Nemo415

Allegedly a well-known member
VIP Supporter
Rating - 100%
95   0   0
Joined
Oct 21, 2014
Messages
1,479
Reaction score
449
Points
1,765
Location
Pretoria
Who is your isp?

Buddy of mine is using an Axxess data account. Has the same issue on outlook, so he uses the Axxess smtp server

smtp.internet.co.za
Port 25
 

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
Who is your isp?

Buddy of mine is using an Axxess data account. Has the same issue on outlook, so he uses the Axxess smtp server

smtp.internet.co.za
Port 25
Dude....wow....i have not tried that....
Do you perhaps know what Cool Ideas' SMTP server settings might be? I'm sure they have one if I remember correctly from before....:unsure:
 
Last edited:

PaladinLaw

Member
Rating - 100%
12   0   0
Joined
Mar 4, 2019
Messages
407
Reaction score
223
Points
945
Age
29
Location
Boksburg, Johannesburg
Hey thanks man, but yes...did all of that. Unbelievable that they can't update their mail server and also not make it more secure. But it definitely seems that they are focusing on Mobile so letting all the "old" stuff go!
Try adding it via control panel and not outlook, as outlook doesn't give you all the options needed.

Close outlook - Control panel - small icon view - mail - email accounts - add new - manual setup - pop/imap - fill in mailbox settings - click more settings - advanced - make sure incoming is 110 - This server required an encrypted connection (SSL) is UNCHECKED - outgoing 25 or 587 (try 25 first) - use the filling type of encryption (none) - click ok - test account settings.

I know you say telkom doesn't support 365 or 2016 / 2019,however, in reality, this doesn't make much sense. Outlook is simply a mail client. It goes and fetches your mail off the server, nothing more, nothing less, and therefore, all forms of mail should work on Outlook provided you have the right settings.

I do however know that telkom email works fine on pre 2016 outlook, and that 2016, 2019 and 365 changed the way you set up accounts in them (hiding some of the options we just found in control panel)

I therefore believe that it's not that Telkom doesn't support Outlook, but rather the settings needed to add the Telkom account are "no longer available" via conventional methods, ie via Outlook.

Telkom therefore either doesn't know the control panel method, or has decided they can't be bothered trying to explain it to their clients, deciding it is simply easier to say that they don't support Outlook.

Give it a try and let me know bud, but I'm confident that seeing it up this way is going to work.

Regards
 

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
.
 

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
Try adding it via control panel and not outlook, as outlook doesn't give you all the options needed.

Close outlook - Control panel - small icon view - mail - email accounts - add new - manual setup - pop/imap - fill in mailbox settings - click more settings - advanced - make sure incoming is 110 - This server required an encrypted connection (SSL) is UNCHECKED - outgoing 25 or 587 (try 25 first) - use the filling type of encryption (none) - click ok - test account settings.

I know you say telkom doesn't support 365 or 2016 / 2019,however, in reality, this doesn't make much sense. Outlook is simply a mail client. It goes and fetches your mail off the server, nothing more, nothing less, and therefore, all forms of mail should work on Outlook provided you have the right settings.

I do however know that telkom email works fine on pre 2016 outlook, and that 2016, 2019 and 365 changed the way you set up accounts in them (hiding some of the options we just found in control panel)

I therefore believe that it's not that Telkom doesn't support Outlook, but rather the settings needed to add the Telkom account are "no longer available" via conventional methods, ie via Outlook.

Telkom therefore either doesn't know the control panel method, or has decided they can't be bothered trying to explain it to their clients, deciding it is simply easier to say that they don't support Outlook.

Give it a try and let me know bud, but I'm confident that seeing it up this way is going to work.

Regards
Thank you for the reply once again!
I know about the work-around through control panel and have been working in the app to test all the various settings.
You are right, it is probably not only Telkom's issue. It seems that from outlook 2016, MS decided that they want some form of authentication protocol to be present in all mail setups even though the "none" option is present.

If I do the auto setup, incoming works fine, but it sets the authentication to STARTTLS. Telkom server does not support SSL, so if I try port 587 with TLS or Auto, it does not accept my password or the username.

I have been to and fro trying all kinds of combinations but to no avail. My last hope is to use Cool Ideas's smtp server. Will phone them today and see if I can get it sorted.

Back to the drawing board....
 

PaladinLaw

Member
Rating - 100%
12   0   0
Joined
Mar 4, 2019
Messages
407
Reaction score
223
Points
945
Age
29
Location
Boksburg, Johannesburg
Thank you for the reply once again!
I know about the work-around through control panel and have been working in the app to test all the various settings.
You are right, it is probably not only Telkom's issue. It seems that from outlook 2016, MS decided that they want some form of authentication protocol to be present in all mail setups even though the "none" option is present.

If I do the auto setup, incoming works fine, but it sets the authentication to STARTTLS. Telkom server does not support SSL, so if I try port 587 with TLS or Auto, it does not accept my password or the username.

I have been to and fro trying all kinds of combinations but to no avail. My last hope is to use Cool Ideas's smtp server. Will phone them today and see if I can get it sorted.

Back to the drawing board....
If you've got teamviewer, i don't mind logging on to take a wack at it for you (you'd need to be present to put your username password etc in) but i can then fiddle around with the other stuff?
 

h0mer

Member
Rating - 100%
10   0   0
Joined
Aug 3, 2018
Messages
272
Reaction score
107
Points
745
If you've got teamviewer, i don't mind logging on to take a wack at it for you (you'd need to be present to put your username password etc in) but i can then fiddle around with the other stuff?
Shot bud, but i am normally very aufeit with these kind of things. But, as I'm sure you know...sometimes 2 pairs of eyes are better than 1 ;)
Spent about an hour with CISP support this morning and could not get a thing sorted. Turns out they do have a smtp server set up specifically for the people who have telkom mail accounts still....like me unfortunately...
It is mailfw1.cisp.co.za or 2 instead of 1....port 587, no

You have PM
 

Top Donors

$200.00
$135.00
$61.00
Top